880 Basic Router Config
880 Basic Router Config
Note
Individual router models may not support every feature described in this guide. Features that are not
supported by a particular router are indicated whenever possible.
This chapter includes configuration examples and verification steps, as available.
3-1
Chapter 3
Interface Ports
Interface Ports
Table 3-1 lists the interfaces that are supported for each router and their associated port labels on the
equipment.
Table 3-1
Router
Interface
Port Label
Cisco 880
LAN, FE0FE3
Wireless LAN
(no label)
WAN, FE4
ADSLoverISDN
ADSLoPOTS
ADSL2oPOTS WAN
ADSLoPOTS
VDSL2oPOTS WAN
VDSLoPOTS
G.SHDSL WAN
G.SHDSL
Default Configuration
When you first boot up your Cisco router, some basic configuration has already been performed. All of
the LAN and WAN interfaces have been created, console and vty ports are configured, and the inside
interface for Network Address Translation (NAT) has been assigned. Use the show running-config
command to view the initial configuration, as shown in the following example for a Cisco 881W:
Router# show running-config
3-2
OL-22206-02
Chapter 3
no aaa new-model
!
!
!
!
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authe
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
ip address 10.1.1.1 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface wlan-ap0
description Service Module interface to manage the embedded AP
ip unnumbered Vlan1
no cdp enable
arp timeout 0
!
ip route 0.0.0.0 0.0.0.0 10.1.1.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
3-3
Chapter 3
line con 0
no modem enable
line aux 0
line vty 0 4
password cisco
login
transport input telnet ssh
!
scheduler max-task-time 5000
!
webvpn cef
end
Router#
If you are setting up a connection to a corporate network, you and the network administrator must
generate and share the following information for the WAN interfaces of the routers:
PPP authentication type: CHAP or PAP
PPP client name to access the router
PPP password to access the router
virtual circuits (PVCs). These PVC parameters are typically virtual path identifier (VPI), virtual
circuit identifier (VCI), and traffic-shaping parameters.
Determine the number of PVCs that your service provider has given you, along with their VPIs
and VCIs.
For each PVC, determine the type of AAL5 encapsulation supported. It can be one of the
following:
AAL5SNAPThis can be either routed RFC 1483 or bridged RFC 1483. For routed RFC 1483,
the service provider must provide you with a static IP address. For bridged RFC 1483, you may
use DHCP to obtain your IP address, or you may obtain a static IP address from your service
provider.
AAL5MUX PPPWith this type of encapsulation, you need to determine the PPP-related
configuration items.
3-4
OL-22206-02
Chapter 3
For ADSL linesEnsure that the ADSL signaling type is DMT (also known as ANSI T1.413)
or DMT Issue 2.
For G.SHDSL linesVerify that the G.SHDSL line conforms to the ITU G.991.2 standard and
supports Annex A (North America) or Annex B (Europe).
After you have collected the appropriate information, you can perform a full configuration on your
router, beginning with the tasks in the Configuring Command-Line Access section on page 3-5.
To obtain or change software licenses, see Software Activation on Cisco Integrated Services Routers and
Cisco Integrated Service Routers G2.
2.
password password
3.
login
4.
5.
6.
password password
7.
login
8.
end
DETAILED STEPS
Step 1
Command
Purpose
Example:
Step 2
password password
Example:
Router(config)# password 5dr4Hepw3
Router(config-line)#
Step 3
login
Example:
Router(config-line)# login
Router(config-line)#
3-5
Chapter 3
Step 4
Command
Purpose
Example:
Router(config-line)# exec-timeout 5 30
Router(config-line)#
Step 5
Example:
Router(config-line)# line vty 0 4
Router(config-line)#
Step 6
password password
Example:
Router(config-line)# password aldf2ad1
Router(config-line)#
Step 7
login
Example:
Router(config-line)# login
Router(config-line)#
Step 8
end
Example:
Router(config-line)# end
Router#
Example
The following configuration shows the command-line access commands.
You do not need to input the commands marked default. These commands appear automatically in the
configuration file generated when you use the show running-config command.
!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
3-6
OL-22206-02
Chapter 3
configure terminal
2.
hostname name
3.
4.
no ip domain-lookup
DETAILED STEPS
Step 1
Command
Purpose
configure terminal
Example:
Router> enable
Router# configure terminal
Router(config)#
Step 2
hostname name
Example:
Router(config)# hostname Router
Router(config)#
Step 3
Example:
Router(config)# enable secret cr1ny5ho
Router(config)#
Step 4
no ip domain-lookup
Example:
Router(config)# no ip domain-lookup
Router(config)#
Configuring ADSL or VDSL on Cisco Multi Mode 886VA and 887VA ISRs, page 3-9
3-7
Chapter 3
2.
3.
no shutdown
4.
exit
DETAILED STEPS
Step 1
Command
Purpose
Example:
Router(config)# interface fastethernet 4
Router(config-if)#
Step 2
Example:
Router(config-if)# ip address 192.168.12.2
255.255.255.0
Router(config-if)#
Step 3
no shutdown
Example:
Router(config-if)# no shutdown
Router(config-if)#
Step 4
exit
Example:
Router(config-if)# exit
Router(config)#
The VDSL2 WAN interface uses Ethernet as the Layer 2 transport mechanism.
To configure VDSL2 on the Cisco 887V ISR, follow these steps, beginning in global configuration
mode:
SUMMARY STEPS
1.
controller vdsl 0
2.
3-8
OL-22206-02
Chapter 3
3.
4.
shutdown
5.
no shutdown
6.
exit
DETAILED STEPS
Step 1
Command
Purpose
controller vdsl 0
Example:
Note
Router# config t
Router(config)# controller vdsl 0
Step 2
Example:
Router(config)# interface ethernet 0
Router(config-if)#
Step 3
Example:
Router(config-if)# ip address 192.168.12.2
255.255.255.0
Router(config-if)#
Step 4
shutdown
Example:
Router(config-if)# no shutdown
Router(config-if)#
Step 5
no shutdown
Example:
Router(config-if)# no shutdown
Router(config-if)#
Step 6
exit
Example:
Router(config-if)# exit
Router(config)#
Configuring ADSL or VDSL on Cisco Multi Mode 886VA and 887VA ISRs
The Cisco customer premise equipment (CPE) 886VA and 887VA Integrated Services Routers (ISRs)
support asymmetric digital subscriber line (ADSL) 1/2/2+ and very high-speed digital subscriber line 2
(VDSL2) transmission modes, also called multi mode. The 886VA supports xDSL over ISDN and the
887VA supports xDSL over a plain old telephone system (POTS).
The default CPE operating mode is auto. Auto mode means that the CPE trains up to the mode configured
on the digital subscriber line access multiplexer (DSLAM), ADSL1/2/2+ or VDSL2.
Cisco 880 Series Integrated Services Router Software Configuration Guide
OL-22206-02
3-9
Chapter 3
The following examples assume the DSLAM is configured in either ADSL2+ mode or VDSL2, and the
CPE is configured in auto mode.
Figure 3-1 shows an ATM WAN or Ethernet WAN network topography.
Figure 3-1
Note
Note
Example Topology
A DSLAM in Layer 1 mode may be configured for auto mode. A DSLAM in Layer 2 mode must be
configured for ATM mode or packet transfer mode (PTM).
Cisco 886VA and 887VA allow a maximum of four permanent virtual circuits (PVCs).
3-10
OL-22206-02
Chapter 3
Configure the DSLAM in ADSL 1/2//2+ mode prior to configuring the router.
SUMMARY STEPS
1.
2.
3.
end
DETAILED STEPS
Step 1
Command
Purpose
Example:
Router (config) #
Controller vdsl 0
Step 2
operating mode
Configures the operating mode. The
{auto|adsl1|adsl2|adsl2+|vdsl2| default is auto and is recommended.
ansl}
Example:
Router (config-controller) #
operating mode
auto
Step 3
end
Example:
Router (config-conroller) #
end
Router
When configured in auto, the operating mode does not appear in the show running command.
2.
no shutdown
3.
3-11
Chapter 3
4.
5.
6.
7.
end
DETAILED STEPS
Command
Step 1
Purpose
Enters configuration mode for the ATM
WAN interface (ATM0).
Step 2
no shutdown
Example:
Step 3
Step 4
Example:
Router (config-subif)# ip address
30.0.0.1 255.255.255.0
Step 5
Step 6
Step 7
end
Example:
3-12
OL-22206-02
Chapter 3
3-13
Chapter 3
Daemon Status:
chip Vendor ID:
Chip Vendor Specific:
Chip Vendor Country:
Up
XTU-R (DS)
BDM
0x0000
0xB500
XTU-C (US)
BDCM
0x6110
0xB500
3-14
OL-22206-02
Chapter 3
csco
BDCM
0x4602
0x6110
0xB500
0xB500
FHK1313227E 887-V2-K 15.1(20100
Modem Status:
DSL Config Mode:
Trained Mode:
TC Mode:
Selftest Result:
DELT configuration:
DELT state:
Trellis:
Line Attenuation:
Signal Attenuation:
Noise Margin:
Atteinable Rate:
Actual Power:
Total FECS:
Total ES:
Total SES:
Total LOSS:
Total UAS:
Total LPRS:
Total LOFS:
Total LOLS:
Bit swap:
TC Sync (Showtime!)
AUTO
G.992.5 (ADSL2+) Annex
ATM
0x00
disabled
not running
ON
1.0 dB
1.0 dB
6.8 dB
25036 kbits/s
13.7 dBm
0
0
0
0
0
0
0
0
163
Full inits:
Failed Full inits:
Short inits:
Failed short inits:
32
0
0
0
Firmware
-------VDSL
Source
-----embedded
Modem FW Version:
Modem PHY Version:
Speed (kbps):
Previous Speed:
Total Cells:
User Cells:
Reed-solomon EC:
CRC Errors:
Header Errors:
Interleave (ms):
Actual INP:
15.1(20100426:193435) [changahn
0x6110
ON
1.4 dB
0.0 dB
13.6 dB
1253 kbits/s
12.3 dBM
0
0
0
0
0
0
0
0
7
Filename (version)
-----------------VDSL_LINUX_DEV_01212008 (1)
100426_1053-4.02L.03.A2pv6C030f.d22j
A2pv6C030f.d22j
DS Channel1
0
0
0
0
0
0
0
0.00
0.00
DS Channel0
24184
24176
317070460
0
0
0
0
0.08
0.00
US Channel1
0
0
0
0
0
0
0
0.00
0.00
US channel0
1047
1047
13723742
0
0
0
0
13.56
1.80
Training Log:
Stopped
Training Log Filename: flash:vdsllog.bin
3-15
Chapter 3
2.
3.
exit
3-16
OL-22206-02
Chapter 3
DETAILED STEPS
Step 1
Command
Purpose
Example:
Router(config)# interface Loopback 0
Router(config-if)#
Step 2
Example:
Router(config-if)# ip address 10.108.1.1
255.255.255.0
Router(config-if)#
Step 3
exit
Example:
Router(config-if)# exit
Router(config)#
Example
The loopback interface in this sample configuration is used to support Network Address Translation
(NAT) on the virtual-template interface. This configuration example shows the loopback interface
configured on the Fast Ethernet interface with an IP address of 200.200.100.1/24, which acts as a static
IP address. The loopback interface points back to virtual-template1, which has a negotiated IP address.
!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
Verifying Configuration
To verify that you have properly configured the loopback interface, enter the show interface loopback
command. You should see a verification output similar to the following example:
Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
3-17
Chapter 3
2.
end
DETAILED STEPS
Step 1
Command
Purpose
Example:
Step 2
end
Example:
Router(config)# end
Router#
3-18
OL-22206-02
Chapter 3
Example
In the following configuration example, the static route sends out all IP packets with a destination IP
address of 192.168.1.0 and a subnet mask of 255.255.255.0 on the Fast Ethernet interface to another
device with an IP address of 10.10.10.2. Specifically, the packets are sent to the configured PVC.
You do not need to enter the command marked (default). This command appears automatically in the
configuration file generated when you use the show running-config command.
!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
Verifying Configuration
To verify that you have properly configured static routing, enter the show ip route command and look
for static routes signified by the S.
You should see a verification output similar to the following:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C
10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
3-19
Chapter 3
router rip
2.
version {1 | 2}
3.
network ip-address
4.
no auto-summary
5.
end
DETAILED STEPS
Step 1
Command
Task
router rip
Example:
Router> configure terminal
Router(config)# router rip
Router(config-router)#
Step 2
version {1 | 2}
Example:
Router(config-router)# version 2
Router(config-router)#
Step 3
network ip-address
Example:
Step 4
no auto-summary
Example:
Router(config-router)# no auto-summary
Router(config-router)#
Step 5
end
Example:
Router(config-router)# end
Router#
3-20
OL-22206-02
Chapter 3
Example
The following configuration example shows RIP version 2 enabled in IP network 10.0.0.0 and
192.168.1.0.
To see this configuration, use the show running-config command from privileged EXEC mode.
!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
Verifying Configuration
To verify that you have properly configured RIP, enter the show ip route command and look for RIP
routes signified by R. You should see a verification output like in the following example:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C
R
2.
network ip-address
3.
end
3-21
Chapter 3
DETAILED STEPS
Step 1
Command
Purpose
Example:
Router(config)# router eigrp 109
Router(config)#
Step 2
network ip-address
Example:
Step 3
end
Example:
Router(config-router)# end
Router#
Example
The following configuration example shows the EIGRP routing protocol enabled in IP networks
192.145.1.0 and 10.10.12.115. The EIGRP autonomous system number is 109.
To see this configuration, use the show running-config command, beginning in privileged EXEC mode.
!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
Verifying Configuration
To verify that you have properly configured IP EIGRP, enter the show ip route command, and look for
EIGRP routes indicated by D. You should see a verification output similar to the following:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C
D
3-22
OL-22206-02