Lab Manual 05 RIP Configuration
Lab Manual 05 RIP Configuration
DCCN - EEE314
Lab 5
RIP Configuration
Islamabad Campus
Lab 05
RIP Configuration
Topology Diagram
DCCN - EEE314
Learning Objectives
Upon completion of this lab, you will be able to:
• Cable a network according to the Topology Diagram.
• Erase the startup configuration and reload a router to the default state.
• Perform basic configuration tasks on a router.
• Configure and activate interfaces.
• Configure RIP routing on all routers.
• Verify RIP routing using showand debugcommands.
• Reconfigure the network to make it contiguous.
• Observe automatic summarization at boundary router.
• Gather information about RIP processing using the debug ip ripcommand.
• Configure a static default route.
• Propagate default routes to RIP neighbors.
• Document the RIP configuration.
Scenarios
• Scenario A: Running RIPv1 on Classful Networks
• Scenario B: Running RIPv1 with Subnets and Between Classful Networks
• Scenario C: Running RIPv1 on a Stub Network.
Pre Lab
Perspective and Background of Dynamic Routing:
Dynamic routing protocols have evolved over several years to meet the demands of changing network
requirements. Although many organizations have migrated to more recent routing protocols such as Enhanced
Interior Gateway Routing Protocol (EIGRP) and Open Shortest Path First (OSPF), many of the earlier routing
protocols, such as Routing Information Protocol (RIP), are still in use today.
One of the earliest routing protocols was RIP. RIP has evolved into a newer version: RIPv2. However, the
newer version of RIP still does not scale to larger network implementations. To address the needs of larger
networks, two advanced routing protocols were developed: OSPF and Intermediate System–to–Intermediate
System (IS-IS). Cisco developed Interior Gateway Routing Protocol (IGRP) and Enhanced IGRP (EIGRP).
EIGRP also scales well in larger network implementations. Additionally, there was the need to interconnect
different internetworks and provide routing among them. Border Gateway Protocol (BGP) is now used
between Internet service providers (ISP) as well as between ISPs and their larger private clients to exchange
routing information.
the primary benefits of using a dynamic routing protocol is that routers exchange routing information
whenever there is a topology change. This exchange allows routers to automatically learn about new networks
and also to find alternate paths if there is a link failure to a current network.
Compared to static routing, dynamic routing protocols require less administrative overhead. However, the
expense of using dynamic routing protocols is dedicating part of a router’s resources for protocol operation,
including CPU time and network link bandwidth. Despite the benefits of dynamic routing, static routing still
has its place. There are times when static routing is more appropriate and other times when dynamic routing is
the better choice. More often than not, you will find a combination of both types of routing in any network
that has a moderate level of complexity.
■ Interior gateway protocols (IGP): Used for intra-autonomous system routing, that is, routing inside an
autonomous system
■ Exterior gateway protocols (EGP): Used for inter-autonomous system routing, that is, routing between
autonomous systems.
Distance vector means that routes are advertised as vectors of distance and direction. Distance is defined in
terms of a metric such as hop count, and direction is simply the nexthop router or exit interface. Distance
vector protocols typically use the Bellman-Ford algorithm for the best-path route determination
In contrast to distance vector routing protocol operation, a router configured with a linkstate routing protocol
can create a “complete view,” or topology, of the network by gathering information from all the other routers.
Think of using a link-state routing protocol as having a complete map of the network topology. The signposts
along the way from source to destination are not necessary, because all link-state routers are using an identical
“map” of the network. A link-state router uses the link-state information to create a topology map and to
select the best path to all destination networks in the topology. With some distance vector routing protocols,
routers send periodic updates of their routing information to their neighbors. Link-state routing protocols do
not use periodic updates. After the network has converged, a link-state update is only sent when there is a
change in the topology.
Classful and Classless Routing Protocols
Classful routing protocols do not send subnet mask information in routing updates. The first routing protocols,
such as RIP, were classful. This was at a time when network addresses were allocated based on classes: Class
A, B, or C. A routing protocol did not need to include the subnet mask in the routing update because the
network mask could be determined based on the first octet of the network address.
Classless routing protocols include the subnet mask with the network address in routing updates. Today’s
networks are no longer allocated based on classes, and the subnet mask cannot be determined by the value of
the first octet. Classless routing protocols are required in most networks today because of their support for
VLSM, discontiguous networks, and other features.
RIP is a standardized Distance Vector protocol, designed for use on smaller networks. RIP was one of the first
true Distance Vector routing protocols, and is supported on a wide variety of systems. RIP adheres to the
following Distance Vector characteristics:
1. RIP sends out periodic routing updates (every 30 seconds)
2. RIP sends out the full routing table every periodic update
3.RIP uses a form of distance as its metric (in this case, hopcount)
4. RIP uses the Bellman-Ford Distance Vector algorithm to determine the best “path” to a particular
destination
Q.1: What are the differences between a distance vector and a link-state routing protocol? What kind of
routing protocol is RIP?
Q.2: What is metric and its parameters?
Q.3: What is the purpose of administrative distance?
Q.2: How do RIP routers to exchange routing information?
Q.3: What is the maximum number of routes that can be sent in a RIP update?
Q.4: What is VLSM? Does RIP support it? Justify your answer.
Q.5: What metric does RIP use?
Q.6: What is difference between RIPv1 and RIPv2?
Scenario A: Running RIPv1 on Classful Networks
Topology Diagram
Addressing Table
Step 1: Cable a network that is similar to the one in the Topology Diagram.
You can use any current router in your lab as long as it has the required interfaces shown in the topology.
Note: If you use 1700, 2500, or 2600 routers, the router outputs and interface descriptions will appear different.
When you have finished, be sure to save the running configuration to the NVRAM of the router.
Step 4: Test the PC configuration by pinging the default gateway from the PC.
Pre Lab Task
R1(config)#router rip
R1(config-router)#
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.2.0
R1(config-router)
The networkcommand:
• Enables RIP on all interfaces that belong to this network. These interfaces will now both send and receive
RIP updates.
• Advertises this network in RIP routing updates sent to other routers every 30 seconds.
When you are finished with the RIP configuration, return to privileged EXEC mode and save the current
configuration to NVRAM.
R1(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
R1#copy run start
Step 3: Configure RIP on the R2 router using the router ripand networkcommands.
R2(config)#router rip
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.4.0
R2(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
R2#copy run start
DCCN - EEE314
When you are finished with the RIP configuration, return to privileged EXEC mode and save the current
configuration to NVRAM.
Step 4: Configure RIP on the R3 router using the router ripand networkcommands.
R3(config)#router rip
R3(config-router)#network 192.168.4.0
R3(config-router)#network 192.168.5.0
R3(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
R3# copy run start
When you are finished with the RIP configuration, return to privileged EXEC mode and save the current
configuration to NVRAM.
Step 1: Use the show ip route command to verify that each router has all of the networks in the topology
entered in the routing table.
Routes learned through RIP are coded with an R in the routing table. If the tables are not converged as shown here,
troubleshoot your configuration. Did you verify that the configured interfaces are active? Did you configure RIP
correctly? Return to Task 3 and Task 4 to review the steps necessary to achieve convergence.
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external,
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR P - periodic downloaded
static route
R2#show ip route
<Output omitted>
R3#show ip route
<Output omitted>
Step 2: Use the show ip protocolscommand to view information about the routing processes.
The show ip protocols command can be used to view information about the routing processes that are occurring on
the router. This output can be used to verify most RIP parameters to confirm that:
• RIP routing is configured
• The correct interfaces send and receive RIP updates
• The router advertises the correct networks
• RIP neighbors are sending updates
R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 16 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 21
Serial0/0/0 1 21
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
192.168.1.0
192.168.2.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
192.168.2.2 120
Distance: (default is 120)
R1#
R1 is indeed configured with RIP. R1 is sending and receiving RIP updates on FastEthernet0/0 and Serial0/0/0.
R1 is advertising networks 192.168.1.0 and 192.168.2.0. R1 has one routing information source. R2 is sending
DCCN - EEE314
R1 updates.
Step 3: Use the debug ip ripcommand to view the RIP messages being sent and received.
Rip updates are sent every 30 seconds so you may have to wait for debug information to be displayed.
R1#debug ip rip
R1#RIP: received v1 update from 192.168.2.2 on Serial0/0/0
192.168.3.0 in 1 hops
192.168.4.0 in 1 hops
192.168.5.0 in 2 hops
RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.1.1)
RIP: build update entries
network 192.168.2.0 metric 1
network 192.168.3.0 metric 2 network
192.168.4.0 metric 2 network 192.168.5.0
metric 3
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (192.168.2.1) RIP: build update entries
network 192.168.1.0 metric 1
The debug output shows that R1 receives an update from R2. Notice how this update includes all the networks that
R1 does not already have in its routing table. Because the FastEthernet0/0 interface belongs to the 192.168.1.0
network configured under RIP, R1 builds an update to send out that interface. The update includes all networks
known to R1 except the network of the interface. Finally, R1 builds an update to send to R2. Because of split
horizon, R1 only includes the 192.168.1.0 network in the update.
Step 4: Discontinue the debug output with the undebug all command.
R1#undebug all
All possible debugging has been turned off
Scenario B: Running RIPv1 with Subnets and Between Classful Networks
Topology Diagram
DCCN - EEE314
Addressing Table
Step 1: Change the IP addressing on the interfaces as shown in the Topology Diagram and the
Addressing Table.
Sometimes when changing the IP address on a serial interface, you may need to reset that interface by using the
shutdown command, waiting for the LINK-5-CHANGED message, and then using the no shutdown command.
This process will force the IOS to starting using the new IP address.
R1(config)#int s0/0/0
R1(config-if)#ip add 172.30.2.1 255.255.255.0
R1(config-if)#shutdown
Notice that only a single network statement is needed for R1. This statement includes both interfaces on different
subnets of the 172.30.0.0 major network.
Again notice that only a single network statement is needed for the two subnets of 172.30.0.0. This statement
includes both interfaces, on different subnets, of the 172.30.0.0 major network. The network for the WAN link
between R2 and R3 is also configured.
When you are finished with the RIP configuration, return to privileged EXEC mode and save the current
configuration to NVRAM.
When you are finished with the RIP configuration, return to privileged EXEC mode and save the current
configuration to NVRAM.
Step 1: Use the show ip route command to verify that each router has all of the networks in the topology in
the routing table.
R1#show ip route
<Output omitted>
Note: RIPv1 is a classful routing protocol. Classful routing protocols do not send the subnet mask with network
in routing updates. For example, 172.30.1.0 is sent by R2 to R1 without any subnet mask information.
R2#show ip route
<Output omitted>
R3#show ip route
<Output omitted>
Then use show ip protocols to verify the RIP configuration. Notice in the output from this command that the
FastEthernet0/0 interface is no longer listed under Interface but is now listed under a new section of the output:
Passive Interface(s).
R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
172.30.0.0
209.165.200.0
Passive Interface(s):
FastEthernet0/0
Routing Information Sources:
Gateway Distance Last Update
209.165.200.229 120 00:00:15
Distance: (default is 120)
Step 3: View the RIP messages being sent and received.
To view the RIP messages being sent and received use the debug ip ripcommand. Notice that RIP
updates are not sent out of the fa0/0 interface because of the passive-interface fastethernet
0/0command.
R1#debug ip rip
R1#RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (172.30.2.1) RIP: build update entries
network 172.30.1.0 metric 1
RIP: received v1 update from 172.30.2.2 on Serial0/0/0
172.30.3.0 in 1 hops
Topology Diagram
DCCN - EEE314
Background
In this scenario we will modify Scenario B to only run RIP between R1 and R2. Scenario C is a typical
configuration for most companies connecting a stub network to a central headquarters router or an ISP. Typically, a
company runs a dynamic routing protocol (RIPv1 in our case) within the local network but finds it unnecessary to
run a dynamic routing protocol between the company’s gateway router and the ISP. For example, colleges with
multiple campuses often run a dynamic routing protocol between campuses but use default routing to the ISP for
access to the Internet. In some cases, remote campuses may even use default routing to the main campus, choosing
to use dynamic routing only locally.
To keep our example simple, for Scenario C, we left the addressing intact from Scenario B. Let’s assume that R3 is
the ISP for our Company XYZ, which consists of the R1 and R2 routers using the 172.30.0.0/16 major network,
subnetted with a /24 mask. Company XYZ is a stub network, meaning that there is only one way in and one way out
of the 172.30.0.0/16 network—in via R2 (the gateway router) and out via R3 (the ISP). It doesn’t make sense for R2
to send R3 RIP updates for the 172.30.0.0 network every 30 seconds, because R3 has no other way to get to
172.30.0.0 except through R2. It makes more sense for R3 to have a static route configured for the 172.30.0.0/16
network pointing to R2.
How about traffic from Company XYZ toward the Internet? It makes no sense for R3 to send over
120,000 summarized Internet routes to R2. All R2 needs to know is that if a packet is not destined for a host on
the 172.30.0.0 network, then it should send the packet to the ISP, R3. This is the same for all other Company
XYZ routers (only R1 in our case). They should send all traffic not destined for the
172.30.0.0 network to R2. R2 would then forward the traffic to R3.
Step 1: Remove network 192.168.4.0 from the RIP configuration for R2.
Remove network 192.168.4.0 from the RIP configuration for R2, because no updates will be sent between
R2 and R3 and we don’t want to advertise the 192.168.4.0 network to R1.
R2(config)#router rip
R2(config-router)#no network 192.168.4.0
Step 2: Completely remove RIP routing from R3.
R3(config)#no router rip
R2(config)#router rip
R2(config-router)#default-information originate
R2(config-router)#
Note: Sometimes it is necessary to clear the RIP routing process before the default-information originate
command will work. First, try the command clear ip route * on both R1 and R2. This command will cause the
routers to immediately flush routes in the routing table and request updates from each other. Sometimes this does
not work with RIP. If the default route information is still not sent to R1, save the configuration on R1 and R2 and
then reload both routers. Doing this will reset the hardware and both routers will restart the RIP routing process.
Step 1: Use the show ip routecommand to view the routing table on R2 and R1.
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external,
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external,
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR P - periodic downloaded
static route
Notice that R1 now has a RIP route tagged as a candidate default route. The route is the “quad-zero” default
route sent by R2. R1 will now send default traffic to the Gateway of last resort at 172.30.2.2, which is the IP
DCCN - EEE314
address of R2.
Step 2: View the RIP updates that are sent and received on R1 with the debug ip ripcommand.
R1#debug ip rip
RIP protocol debugging is on
R1#RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (172.30.2.1)
RIP: build update entries
network 172.30.1.0 metric 1
RIP: received v1 update from 172.30.2.2 on Serial0/0/0
0.0.0.0 in 1 hops
172.30.3.0 in 1 hops
Step 4: Use the show ip routecommand to view the routing table on R3.
R3#show ip route
<Output omitted>
Notice that RIP is not being used on R3. The only route that is not directly connected is the static route.
Task 5: Document the Router Configurations
On each router, capture the following command output to a text file and save for future reference:
• Running configuration
• Routing table
• Interface summarization
• Output from show ip protocols
Task 6: Clean Up
Erase the configurations and reload the routers. Disconnect and store the cabling. For PC hosts that are normally
connected to other networks (such as the school LAN or to the Internet), reconnect the appropriate cabling and
restore the TCP/IP settings.
DCCN - EEE314
RIPv2 Configuration Lab
Topology Diagram
Addressing Table
DCCN - EEE314
Scenario
The network shown in the Topology Diagram contains a discontiguous network, 172.30.0.0. This network has been
subnetted using VLSM. The 172.30.0.0 subnets are physically and logically divided by at least one other classful or
major network, in this case the two serial networks 209.165.200.228/30 and
209.165.200.232/30. This can be an issue when the routing protocol used does not include enough information to
distinguish the individual subnets. RIPv2 is a classless routing protocol that can be used to provide subnet mask
information in the routing updates. This will allow VLSM subnet information to be propagated throughout the
DCCN - EEE314
network.
hostname R2
!
DCCN - EEE314
!
!
interface FastEthernet0/0
ip address 10.1.0.1 255.255.0.0 duplex auto
speed auto
no shutdown
!
interface Serial0/0/0
ip address 209.165.200.229 255.255.255.252
no shutdown
!
interface Serial0/0/1
ip address 209.165.200.233 255.255.255.252 clock rate 64000
no shutdown
!
router rip
passive-interface FastEthernet0/0 network
10.0.0.0
network 209.165.200.0
!
line con 0
line vty 0 4 login
!
end
network 209.165.200.0
!
line con 0 line vty
04
login
!
end
Step 2: Check the connectivity from R2 to the hosts on the R1 and R3 LANs.
Note: For the 1841 router, you will need to disable IP CEF to obtain the correct output from the ping command.
Although a discussion of IP CEF is beyond the scope of this course, you may disable IP CEF by using the
following command in global configuration mode:
R2(config)#no ip cef
From the R2 router, how many ICMP messages are successful when pinging PC1?
From the R2 router, how many ICMP messages are successful when pinging PC4?
__
R2#show ip route
Output omitted
R1#show ip route
Output omitted
R3#show ip route
Output omitted
Step 7: Examine the RIPv1 packets that are being received by R2.
Use the debug ip ripcommand to display RIP routing updates.
R2 is receiving the route 172.30.0.0, with 1 hop, from both R1 and R3. Because these are equal cost metrics, both
routes are added to the R2 routing table. Because RIPv1 is a classful routing protocol, no subnet mask information
is sent in the update.
R2#debug ip rip
RIP protocol debugging is on
RIP: received v1 update from 209.165.200.234 on Serial0/0/1
172.30.0.0 in 1 hops
RIP: received v1 update from 209.165.200.230 on Serial0/0/0
172.30.0.0 in 1 hops
R2 is sending only the routes for the 10.0.0.0 LAN and the two serial connections to R1 and R3. R1 and R3
are not receiving any information about the 172.30.0.0 subnet routes.
R2#undebug all
Step 1: Use the version 2command to enable RIP version 2 on each of the routers.
R2(config)#router rip
R2(config-router)#version 2
R1(config)#router rip
R1(config-router)#version 2
R3(config)#router rip
R3(config-router)#version 2
RIPv2 messages include the subnet mask in a field in the routing updates. This allows subnets and their masks to be
included in the routing updates. However, by default RIPv2 summarizes networks at major network boundaries,
DCCN - EEE314
just like RIPv1, except that the subnet mask is included in the update.
R2#show ip route
Output omitted
R1 still shows only its own subnets for the 172.30.0.0 network. R1 still does not have any routes for the
172.30.0.0 subnets on R3.
R1#show ip route
Output omitted
DCCN - EEE314
R3 still only shows its own subnets for the 172.30.0.0 network. R3 still does not have any routes for the
172.30.0.0 subnets on R1.
R3#show ip route
Output omitted
On R2, what routes are in the RIP updates that are received from R3?
R3 is not sending any of the 172.30.0.0 subnets—only the summarized route of 172.30.0.0/16, including the subnet
mask. This is why R2 and R1 are not seeing the 172.30.0.0 subnets on R3.
DCCN - EEE314
R2(config)#router rip
R2(config-router)#no auto-summary
R1(config)#router rip
R1(config-router)#no auto-summary
R3(config)#router rip
R3(config-router)#no auto-summary
The show ip routeand pingcommands can be used to verify that automatic summarization is off.
R2#show ip route
Output omitted
R1#show ip route
Output omitted
R3#show ip route
Output omitted
Use the output of the debug ip rip command to answer the following questions: What
entries are included in the RIP updates sent out from R1?
On R2, what routes are in the RIP updates that are received from R1?
From R2, how many ICMP messages are successful when pinging PC4?
Task 9: Documentation
On each router, capture the following command output to a text (.txt) file and save for future reference.
show running-config
show ip route
show ip interface brief
show ip protocols
If you need to review the procedures for capturing command output, refer to Lab 1.5.1.
Task 10: Clean Up
Erase the configurations and reload the routers. Disconnect and store the cabling. For PC hosts that are normally
connected to other networks (such as the school LAN or to the Internet), reconnect the appropriate cabling and
restore the TCP/IP settings.
Critical Analysis/Conclusion
DCCN - EEE314
Lab Assessment
Pre Lab /5
Performance /5
/25
Results /5
Viva /5
Critical Analysis /5