SD-WAN PRACTICE LAB PNETLAB v1 Draft
SD-WAN PRACTICE LAB PNETLAB v1 Draft
PNETLAB Store
PNETLab.com
Lab Topology
1
Download PNETLab Platform
PNETLAB Store
PNETLab.com
Table of Contents
HOW TO SETUP LAB ...................................................................................................................................... 4
Hardware Requirement ............................................................................................................................ 4
Link to download lab and Setup ............................................................................................................... 4
Lab 1: Configuring the WAN Components .................................................................................................... 5
Task 1 – HQ Router Configuration ............................................................................................................ 5
Task 2 – MPLS Cloud Router Configuration .............................................................................................. 6
Task 3- Internet Cloud Router Configuration ............................................................................................ 7
Lab 2: Installing the Enterprise Certificate Server ........................................................................................ 7
Task 1- Configure the interface................................................................................................................. 7
Task 2- Configure the Timezone and Time ............................................................................................... 9
Task 3- Installing the Enterprise Root Certificate Server .......................................................................... 9
Task 4 Install WinSCP .............................................................................................................................. 15
Lab 3- Initializing vManage -CLI .................................................................................................................. 16
Task 1- Configuring the System Component........................................................................................... 16
Task 2- Configured the VPN parameters................................................................................................. 16
Lab 4- Initializing vManage – GUI................................................................................................................ 18
Task 1- Organization name & vBond Address......................................................................................... 18
Task 2 – Configure Controller Authorization as Enterprise Root and Download the Root Certificate. .. 18
Task 3- Generate a CSR for vManage...................................................................................................... 22
Task 4 – Request a Certificate from the CA Server ................................................................................. 23
Task 5 – Issue the Certificate from the CA Server................................................................................... 25
Task 6- Downloading the Issueed Certificate.......................................................................................... 26
Task 7- Installing the Identity Certificate for vManage........................................................................... 29
Lab 5- Initializing vBond – CLI ..................................................................................................................... 31
Task 1- Configuring the System component ........................................................................................... 31
Task 2 – Configure the vpn parameters .................................................................................................. 31
Lab 6- Initializing vBond -GUI ...................................................................................................................... 33
Task 1 – Add vBond to vManage............................................................................................................. 33
Task 2 – View the generated CSR for vBond and copy it ........................................................................ 33
Task 3- Request a certificate from the CA Server ................................................................................... 35
Task 4 – Issue the Certificate from the CA Server................................................................................... 37
Task 5- Downloading the Issued Certificate............................................................................................ 37
2
Download PNETLab Platform
PNETLAB Store
PNETLab.com
3
Download PNETLab Platform
PNETLAB Store
PNETLab.com
4
Download PNETLab Platform
PNETLAB Store
PNETLab.com
HQ
MPLS-Cloud
Interface-Cloud
HQ Router
hostname HQ
!
interface Ethernet0/0
ip address 100.1.1.1 255.255.255.0
!
interface Ethernet0/1
5
Download PNETLab Platform
PNETLAB Store
PNETLab.com
hostname MPLS
!
interface Ethernet0/0
ip address 10.1.11.2 255.255.255.0
!
interface Ethernet0/1
ip address 10.1.12.2 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet0/2
ip address 10.1.13.2 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet0/3
ip address 10.1.14.2 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet1/0
ip address 10.1.15.2 255.255.255.0
ip ospf network point-to-point
!
6
Download PNETLab Platform
PNETLAB Store
PNETLab.com
router ospf 1
network 10.1.11.0 0.0.0.255 area 0
network 10.1.12.0 0.0.0.255 area 0
network 10.1.13.0 0.0.0.255 area 0
network 10.1.14.0 0.0.0.255 area 0
network 10.1.15.0 0.0.0.255 area 0
hostname Internet
!
no ip domain lookup
ip cef
!
interface Ethernet0/0
ip address 118.1.1.2 255.255.255.0
!
interface Ethernet0/1
ip address 118.1.2.1 255.255.255.0
!
interface Ethernet0/2
ip address 118.1.3.2 255.255.255.0
!
interface Ethernet0/3
ip address 118.1.4.2 255.255.255.0
!
interface Ethernet1/0
ip address 118.1.5.2 255.255.255.0
!
ip route 100.1.1.0 255.255.255.0 118.1.1.1
7
Download PNETLab Platform
PNETLAB Store
PNETLab.com
8
Download PNETLab Platform
PNETLAB Store
PNETLab.com
9
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Click Next
10
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Click Next
- Select “Certification authority Web enrollment” and click Next
11
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Leave the default for the Cryptography for CA and click Next
13
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Leave the default for the Validity Period and click Next
14
Download PNETLab Platform
PNETLAB Store
PNETLab.com
15
Download PNETLab Platform
PNETLAB Store
PNETLab.com
Note:
vManage
config
!
system
host-name vManage1
system-ip 10.10.10.1
site-id 1
organization-name PNETLAB
clock timezone America/Antigua
vbond 100.1.1.4
!
commit
vManage
config
!
vpn 0
no interface eth0
interface eth1
16
Download PNETLab Platform
PNETLAB Store
PNETLab.com
ip address 100.1.1.2/24
tunnel-interface
allow-service all
allow-service netconf
allow-service sshd
no shut
ip route 0.0.0.0/0 100.1.1.1
!
vpn 512
interface eth0
ip address 192.168.100.2/24
no shut
!
commit
17
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Click Edit on the Organization name and set it to PNETLAB. Confirm the Organization
name. Click OK.
- Click Edit on the vBond address and change it to 100.1.1.4. Confirm and click OK.
Task 2 – Configure Controller Authorization as Enterprise Root and Download the Root
Certificate.
- Browse to http://100.1.1.5/certsrv
- Click “Download Root Certificate”.
18
Download PNETLab Platform
PNETLAB Store
PNETLab.com
20
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Set the CSR Parameters with the Organization name, City, State, Country. Set the
Time to 3 Years and save.
21
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- It will open a windows with CSR. Copy by using CTRL-A and CTRL-C
22
Download PNETLab Platform
PNETLAB Store
PNETLab.com
23
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Select “advanced”
- Paste the CSR in the box by using CTRL-V and click submit
24
Download PNETLab Platform
PNETLAB Store
PNETLab.com
25
Download PNETLab Platform
PNETLAB Store
PNETLab.com
26
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- The issued certificate link will show up. Click on the link
28
Download PNETLab Platform
PNETLAB Store
PNETLab.com
29
Download PNETLab Platform
PNETLAB Store
PNETLab.com
30
Download PNETLab Platform
PNETLAB Store
PNETLab.com
Note:
vBond
config
!
system
host-name vBond1
system-ip 10.10.10.3
site-id 1
organization-name PNETLAB
clock timezone America/Antigua
vbond 100.1.1.4 local
!
commit
vBond
config
!
vpn 0
no interface eth0
31
Download PNETLab Platform
PNETLAB Store
PNETLab.com
interface ge0/0
ip address 100.1.1.4/24
tunnel-interface
encapsulation ipsec
allow-service all
allow-service netconf
allow-service sshd
no shut
ip route 0.0.0.0/0 100.1.1.1
!
vpn 512
interface eth0
ip address 192.168.100.4/24
no shut
!
commit
32
Download PNETLab Platform
PNETLAB Store
PNETLab.com
33
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- It will open a windows with CSR. Copy by using CTRL-A and CTRL-C
34
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Select “Advanced”
35
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Paste the CSR in the box by using CTRL-V and click Submit
36
Download PNETLab Platform
PNETLAB Store
PNETLab.com
37
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- The issued certificate link will show up. Click on the link
38
Download PNETLab Platform
PNETLAB Store
PNETLab.com
39
Download PNETLab Platform
PNETLAB Store
PNETLab.com
40
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- The Identity certificate should be installed for vBond and pushed to it.
41
Download PNETLab Platform
PNETLAB Store
PNETLab.com
42
Download PNETLab Platform
PNETLAB Store
PNETLab.com
VSmart
config
!
system
host-name vSmart1
system-ip 10.10.10.3
site-id 1
organization-name PNETLAB
clock timezone America/Antigua
vbond 100.1.1.3
!
commit
vSmart
config
!
vpn 0
no interface eth0
interface eth1
ip address 100.1.1.3/24
tunnel-interface
43
Download PNETLab Platform
PNETLAB Store
PNETLab.com
allow-service all
allow-service netconf
allow-service sshd
no shut
ip route 0.0.0.0/0 100.1.1.1
!
vpn 512
interface eth0
ip address 192.168.100.3/24
no shut
!
commit
44
Download PNETLab Platform
PNETLAB Store
PNETLab.com
45
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- It will open a window with CSR. Copy by using CTRL-A and CTRL-C
46
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Select “Advanced”
47
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Paste the CSR in the box by using CTRL-V and click Submit
48
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- The issued certificate link will show up. Click on the link
49
Download PNETLab Platform
PNETLAB Store
PNETLab.com
50
Download PNETLab Platform
PNETLAB Store
PNETLab.com
51
Download PNETLab Platform
PNETLAB Store
PNETLab.com
52
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- The Identity certificate should be installed for vSmart and pushed to it.
53
Download PNETLab Platform
PNETLAB Store
PNETLab.com
- Select the file you downloaded from the PNP Portal. Upload it and check the Validate option.
54
Download PNETLab Platform
PNETLAB Store
PNETLab.com
55
Download PNETLab Platform
PNETLAB Store
PNETLab.com
vEDGE-1
56