QB Array Program Answers
QB Array Program Answers
Sample Input:
Rohit, Devesh, Indrani, Shivangi, Himanshu, Rishi, Piyush, Deepak, Abhishek, Kunal , .....
Sample Output:
Abhishek, Deepak, Devesh, Himanshu, Indrani, Kunal, Piyush, Rishi, Rohit, Shivangi, ..…*/
import java.util.*;
System.out.println("Enter 20 names");
for(int i=0;i<20;i++)
a[i]=sc.nextLine();
String temp="";
for(int i=0;i<19;i++)
for(int j=0;j<19-i;j++)
if(a[j].compareTo(a[j+1])>0)
1
temp=a[j];
a[j]=a[j+1];
a[j+1]=temp;
for(int i=0;i<20;i++)
System.out.println(a[i]);
2. Write a program to accept the names of 10 cities in a single dimensional string array and their STD
(Subscribers Trunk Dialling) codes in another single dimension integer array. Search for the name of a
city input by the user in the list. If found, display "Search Successful" and print the name of the city along
with its STD code, or else display the message "Search unsuccessful, no such city in the list".
import java.util.*;
2
for (int i = 0; i < 10; i++)
cities[i] = sc.nextLine();
stdcodes[i] = sc.nextLine();
int index=0,temp=0;
if (city.equalsIgnoreCase(cities[i]) )
temp=1;
index=i;
break;
if (temp==1)
System.out.println("Search Successful");
3
else
System.out.println("Search Unsuccessful");
3. Write a program to search for an integer value input by the user in the sorted list given below using
binary search technique . If found display“ Search Successful”, otherwise display “Search Unsuccessful”.
{31,36,45,50,60,75, 86,90}
import java.util.*;
int a[]={31,36,45,50,60,75,86,90};
int n=sc.nextInt();
int f=0,l=a.length-1,mid=0,temp;
while(f<=l)
mid=(f+l)/2;
if(n>a[mid])
f=mid+1;
if(n<a[mid])
l=mid-1;
if(n==a[mid])
4
{
temp=1;
break;
if(temp==1)
System.out.println("Search successful");
else
System.out.println("Search unsuccessful");
} }
4. Define a class to accept 10 integers and arrange them in descending order using bubble sort. Print the
original array and the sorted array.
import java.util.*;
System.out.println("Enter 10 elements");
for(int i=0;i<10;i++)
a[i]=sc.nextInt();
int temp=0;
5
for(int i=0;i<9;i++)
for(int j=0;j<9-i;j++)
if(a[j]<a[j+1])
temp=a[j];
a[j]=a[j+1];
a[j+1]=temp;
}}}
for(int i=0;i<10;i++)
System.out.println(a[i]);
} } }
5. Define a class to accept values into a double array of size 20 and print the range of the array, range is
the difference between the largest and the smallest elements of the array also print the sum and
product of the elements.
import java.util.*;
6
System.out.println("Enter 20 numbers");
for(int i=0;i<20;i++)
a[i]=sc.nextDouble();
double max=a[0],min=a[0],sum=0,pro=1;
for(int i=0;i<20;i++)
if(a[i]>max)
max=a[i];
if(a[i]<min)
min=a[i];
sum=sum+a[i];
pro=pro*a[i];
System.out.println("Largest number="+max);
System.out.println("Smallest number="+min);
System.out.println("sum="+sum);
System.out.println("Product="+pro);
6. Define a class to accept the names of 10 students in an array and check for the existence of the given
name in the array using linear search ,if found print the position of the name, if not found print the
appropriate message. Also print the names which begins with the word “SRI”.
import java.util.*;
7
{
System.out.println("Enter 10 names");
for(int i=0;i<10;i++)
a[i]=sc.nextLine();
String s=sc.nextLine();
int temp=0;
for(int i=0;i<10;i++)
if(a[i].equalsIgnoreCase(s))
temp=1;
break;
if(temp==1)
System.out.println("search successful");
else
System.out.println("search unsuccessful");
8
for(int i=0;i<10;i++)
if(a[i].startsWith("SRI"))
System.out.println(a[i]);
7. Write a program to input name & temperature of 10 cities and display the maximum and minimum
temperature with its city name .
import java.util.*;
for(int i=0;i<10;i++)
city[i]=sc.next();
System.out.println("Enter temperature");
9
t[i]=sc.nextDouble();
String max_c=city[0],min_c=city[0];
for(int i=0;i<10;i++)
if(t[i]>max)
max=t[i];
max_c=city[i];
if(t[i]<min)
min=t[i];
min_c=city[i];
System.out.println("maximum temperature="+max);
System.out.println("minimum temperature="+min);
10
8. Define a class and store the 10 state and their capital city names in 2 separate single dimensional
array and sort them in ascending order using bubble sort.
import java.util.*;
for(int i=0;i<10;i++)
state[i]=sc.nextLine();
capital[i]=sc.nextLine();
String temp1="",temp2="";
for(int i=0;i<9;i++)
for(int j=0;j<9-i;j++)
if(state[j].compareTo(state[j+1])>0)
11
temp1=state[j];
state[j]=state[j+1];
state[j+1]=temp1;
temp2=capital[j];
capital[j]= capital[j+1];
capital[j+1]=temp2;
System.out.println("State"+"\t"+"capital");
for(int i=0;i<10;i++)
System.out.println(state[i]+"\t"+capital[i]);
9. Write a program to accept a list of 20 integers. Sort the first 10 numbers in ascending order
and next the 10 numbers in descending order by using 'Bubble Sort' technique. Finally, print
import java.util.*;
12
{
System.out.println("Enter 20 numbers");
for(int i=0;i<20;i++)
a[i]=sc.nextInt();
int temp=0;
for(int i=0;i<9;i++)
for(int j=0;j<9-i;j++)
if(a[j]>a[j+1])
temp=a[j];
a[j]=a[j+1];
a[j+1]=temp;
temp=0;
for(int i=10;i<19;i++)
for(int j=10;j<19;j++)
13
{
if(a[j]<a[j+1])
temp=a[j];
a[j]=a[j+1];
a[j+1]=temp;
System.out.println("sorted list");
for(int i=0;i<20;i++)
System.out.println(a[i]);
10. Write a program in Java to store 20 numbers (even and odd numbers) in a Single
Dimensional Array (SDA). Calculate and display the sum of all even numbers and all odd
numbers separately.
import java.util.*;
14
Scanner sc= new Scanner(System.in);
System.out.println("Enter 20 numbers");
for(int i=0;i<20;i++)
a[i]=sc.nextInt();
int sum=0,pro=1;
for(int i=0;i<20;i++)
if(a[i]%2==0)
sum=sum+a[i];
else
product=pro*a[i];
15