Cisco Basic Router Configuration
Cisco Basic Router Configuration
Interface Port Labels Viewing the Default Configuration Information Needed for Configuration Configuring Basic Parameters Configuring Static Routes Configuring Dynamic Routes Configuring Enhanced IGRP
Each section includes a configuration example and verification steps, as available. For complete information on how to access global configuration mode, see the Entering Global Configuration Mode section in Appendix A, Cisco IOS Basic Skills. For more information on the commands used in the following tables, see the Cisco IOS Release 12.3 documentation set.
Interface Fast Ethernet LANs Fast Ethernet WANs ATM WAN Wireless LAN BRI
Port Label SWITCH and FE8FE5 (top), FE x and FE4FE1 (bottom) FE0 ADSLoPOTS LEFT, RIGHT/PRIMARY ISDN S/T
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide OL-6426-02
1-1
Table 1
Interface Fast Ethernet LANs Fast Ethernet WANs ATM WAN Wireless LAN BRI
Port Label SWITCH and FE8FE5 (top), FE x and FE4FE1 (bottom) FE0 ADSLoISDN LEFT, RIGHT/PRIMARY ISDN S/T SWITCH and FE8FE5 (top), FE x and FE4FE1 (bottom) FE0 G.SHDSL LEFT, RIGHT/PRIMARY ISDN S/T SWITCH and FE9FE6 (top), FE x and FE5FE2 (bottom) FE0FE1 LEFT, RIGHT/PRIMARY 10 MODEM SWITCH and FE9FE6 (top), FE x and FE5FE2 (bottom) FE0FE1 LEFT, RIGHT/PRIMARY ISDN S/T 10
Cisco 1803
Fast Ethernet LANs Fast Ethernet WANs ATM WAN Wireless LAN BRI
Cisco 1811
Fast Ethernet LANs Fast Ethernet WANs Wireless LAN USB V.92
Cisco 1812
Fast Ethernet LANs Fast Ethernet WANs Wireless LAN BRI USB
Note
If you are unable to view the initial configuration and you get a No Password Set error message, you must reset the initial password. For details, see the Recovering a Lost Password section in Chapter 14, Troubleshooting.
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
1-2
OL-6426-02
Chapter 1
Example 1
version 12.3 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption ! hostname Router ! boot-start-marker boot-end-marker ! mmi polling-interval 60 no mmi auto-configure no mmi pvc mmi snmp-timeout 180 no aaa new-model ip subnet-zero ! ip cef ! ip ips po max-events 100 no ftp-server write-enable ! interface BRI0 no ip address shutdown ! interface FastEthernet0 no ip address shutdown duplex auto speed auto ! interface FastEthernet1 no ip address shutdown duplex auto speed auto ! interface FastEthernet2 no ip address shutdown ! interface FastEthernet3 no ip address shutdown ! interface FastEthernet4 no ip address shutdown ! interface FastEthernet5 no ip address shutdown ! interface FastEthernet6 no ip address shutdown ! interface FastEthernet7 no ip address shutdown !
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide OL-6426-02
1-3
interface FastEthernet8 no ip address shutdown ! interface FastEthernet9 no ip address shutdown ! interface Vlan1 no ip address ! ip classless ! no ip http server no ip http secure-server ! control-plane ! line con 0 line aux 0 line vty 0 4 ! no scheduler allocate end
If you are setting up a connection to a corporate network, you and the network administrator must generate and share the following information for the WAN interfaces of the routers:
PPP authentication type: CHAP or PAP PPP client name to access the router PPP password to access the router
virtual circuits (PVCs). These PVC parameters are typically virtual path identifier (VPI), virtual circuit identifier (VCI), and traffic shaping parameters.
Determine the number of PVCs that your service provider has given you, along with their VPIs
and VCIs.
For each PVC determine the type of AAL5 encapsulation supported. It can be one of the
following:
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
1-4
OL-6426-02
Chapter 1
AAL5SNAPThis can be either routed RFC 1483 or bridged RFC 1483. For routed RFC 1483, the service provider must provide you with a static IP address. For bridged RFC 1483, you may use DHCP to obtain your IP address, or you may obtain a static IP address from your service provider. AAL5MUX PPPWith this type of encapsulation, you need to determine the PPP-related configuration items.
For ADSL linesEnsure that the ADSL signaling type is DMT (also called ANSI T1.413) or DMT Issue 2. For G.SHDSL linesVerify that the G.SHDSL line conforms to the ITU G.991.2 standard and supports Annex A (North America) or Annex B (Europe). Once you have collected the appropriate information, you can perform a full configuration on your router, beginning with the tasks in the Configuring Basic Parameters section.
Configure Global Parameters Configure Fast Ethernet LAN Interfaces Configure WAN Interfaces Configuring a Loopback Interface Configuring Command-Line Access to the Router
A configuration example is presented with each task to show the network configuration following completion of that task.
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide OL-6426-02
1-5
Purpose Enters global configuration mode, when using the console port. If you are connecting to the router using a remote terminal, use the following:
telnet router name or address Login: login id Password: ********* Router> enable
configure terminal
Example:
Router> enable Router# configure terminal Router(config)#
Step 2
hostname name
Example:
Router(config)# hostname Router Router(config)#
Step 3
Step 4
no ip domain-lookup
Example:
Router(config)# no ip domain-lookup Router(config)#
Disables the router from translating unfamiliar words (typos) into IP addresses.
For complete information on the global parameter commands, see the Cisco IOS Release 12.3 documentation set.
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
1-6
OL-6426-02
Chapter 1
Configure the Fast Ethernet WAN Interface Configure the ATM WAN Interface
Purpose Enters the configuration mode for a Fast Ethernet WAN interface on the router.
Note
Fast Ethernet WAN ports are numbered 01 on the Cisco 1800 series routers.
Step 2
Sets the IP address and subnet mask for the specified Fast Ethernet interface.
Step 3
no shutdown
Example:
Router(config-int)# no shutdown Router(config-int)#
Enables the Ethernet interface, changing its state from administratively down to administratively up.
Step 4
exit
Example:
Router(config-int)# exit Router(config)#
Repeat these steps for the other Fast Ethernet WAN interface if desired.
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide OL-6426-02
1-7
Command
Step 1
Purpose For routers using the G.SHDSL signaling, perform these commands. Ignore this step for routers using ADSL signaling.
For the Cisco 1803 only: controller dsl 0 mode atm exit
Example:
Router(config)# controller dsl 0 Router(config-controller)# mode atm Router(config-controller)# exit Router(config)#
Step 2
Step 3
Sets the IP address and subnet mask for the ATM interface.
Step 4
no shutdown
Example:
Router(config-int)# no shutdown Router(config-int)#
Step 5
exit
Example:
Router(config-int)# exit Router(config)#
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
1-8
OL-6426-02
Chapter 1
Step 2
Sets the IP address and subnet mask for the loopback interface.
Step 3
exit
Example:
Router(config-int)# exit Router(config)#
Exits configuration mode for the loopback interface and returns to global configuration mode.
Configuration Example
The loopback interface in this sample configuration is used to support Network Address Translation (NAT) on the virtual-template interface. This configuration example shows the loopback interface configured on the Fast Ethernet interface with an IP address of 200.200.100.1/24, which acts as a static IP address. The loopback interface points back to virtual-template1, which has a negotiated IP address.
! interface loopback 0 ip address 200.200.100.1 255.255.255.0 (static IP address) ip nat outside ! interface Virtual-Template1 ip unnumbered loopback0 no ip directed-broadcast ip nat outside
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide OL-6426-02
1-9
Purpose Enters line configuration mode, and specifies the type of line. This example specifies a console terminal for access. Specifies a unique password for the console terminal line.
Step 2
password password
Example:
Router(config)# password 5dr4Hepw3 Router(config)#
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
1-10
OL-6426-02
Chapter 1
Command
Step 3
login
Example:
Router(config)# login Router(config)#
Step 4
Sets the interval that the EXEC command interpreter waits until user input is detected. The default is 10 minutes. Optionally, add seconds to the interval value. This example shows a timeout of 5 minutes and 30 seconds. Entering a timeout of 0 0 specifies never to time out. Specifies a virtual terminal for remote console access.
Step 5
Step 6
password password
Example:
Router(config)# password aldf2ad1 Router(config)#
Step 7
login
Example:
Router(config)# login Router(config)#
Step 8
end
Example:
Router(config)# end Router#
For complete information about the command line commands, see the Cisco IOS Release 12.3 documentation set.
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide OL-6426-02
1-11
Configuration Example
The following configuration shows the command-line access commands. You do not need to input the commands marked default. These commands appear automatically in the configuration file generated when you use the show running-config command.
! line con 0 exec-timeout 10 0 password 4youreyesonly login transport input none (default) stopbits 1 (default) line vty 0 4 password secret login !
Purpose Specifies the static route for the IP packets. For details about this command and additional parameters that can be set, see the Cisco IOS IP Command Reference, Volume 2 of 4: Routing Protocols.
Step 2
end
Example:
Router(config)# end Router#
For complete information on the static routing commands, see the Cisco IOS Release 12.3 documentation set. For more general information on static routing, see Appendix B, Concepts.
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
1-12
OL-6426-02
Chapter 1
Configuration Example
In the following configuration example, the static route sends out all IP packets with a destination IP address of 192.168.1.0 and a subnet mask of 255.255.255.0 on the Fast Ethernet interface to another device with an IP address of 10.10.10.2. Specifically, the packets are sent to the configured PVC. You do not need to enter the commands marked (default). These commands appear automatically in the configuration file generated when you use the show running-config command.
! ip classless (default) ip route 192.168.1.0 255.255.255.0 10.10.10.2!
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide OL-6426-02
1-13
Configuring RIP
Perform these steps to configure the RIP routing protocol on the router, beginning in global configuration mode: Command
Step 1
Task Enters router configuration mode, and enables RIP on the router.
router rip
Example:
Router> configure terminal Router(config)# router rip Router(config-router)#
Step 2
version {1 | 2}
Example:
Router(config-router)# version 2 Router(config-router)#
Step 3
network ip-address
Example:
Router(config-router)# network 192.168.1.1 Router(config-router)# network 10.10.7.1 Router(config-router)#
Specifies a list of networks on which RIP is to be applied, using the address of the network of directly connected networks.
Step 4
no auto-summary
Example:
Router(config-router)# no auto-summary Router(config-router)#
Disables automatic summarization of subnet routes into network-level routes. This allows subprefix routing information to pass across classful network boundaries.
Step 5
end
Example:
Router(config-router)# end Router#
For complete information on the dynamic routing commands, see the Cisco IOS Release 12.3 documentation set. For more general information on RIP, see Appendix B, Concepts.
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
1-14
OL-6426-02
Chapter 1
Configuration Example
The following configuration example shows RIP version 2 enabled in IP network 10.0.0.0 and 192.168.1.0. Execute the show running-config command from privileged EXEC mode to see this configuration.
! router rip version 2 network 10.0.0.0 network 192.168.1.0 no auto-summary !
C R
Purpose Enters router configuration mode, and enables EIGRP on the router. The autonomous-system number identifies the route to other EIGRP routers and is used to tag the EIGRP information.
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide OL-6426-02
1-15
Command
Step 2
Purpose Specifies a list of networks on which EIGRP is to be applied, using the IP address of the network of directly connected networks.
network ip-address
Example:
Router(config)# network 192.145.1.0 Router(config)# network 10.10.12.115 Router(config)#
Step 3
end
Example:
Router(config-router)# end Router#
For complete information on the IP EIGRP commands, see the Cisco IOS Release 12.3 documentation set. For more general information on EIGRP concepts, see Appendix B, Concepts.
Configuration Example
The following configuration example shows the EIGRP routing protocol enabled in IP networks 192.145.1.0 and 10.10.12.115. The EIGRP autonomous system number is assigned as 109. Execute the show running-config command from privileged EXEC mode to see this configuration.
! router eigrp 109 network 192.145.1.0 network 10.10.12.115 !
C D
Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
1-16
OL-6426-02